backtop


Print 35 comment(s) - last by HighWing.. on Nov 13 at 12:57 PM


iPhone 1.1.1 prepped for 1.1.2 jailbreak  (Source: TUAW)
Apple's latest effort to thwart iPhone and iPod touch hacking futile

When Apple announced the release of the iPhone for the UK, it also announced that iPhone and iPod touch firmware version 1.1.2 would be released at the same time. Released today, firmware 1.1.2 closes the TIFF vulnerability in mobile Safari that was used to jailbreak firmware 1.1.1.

Confirmed by DailyTech, the TIFF vulnerability no longer works. However, despite Apple's effort to lockdown the iPhone and iPod touch, firmware 1.1.2 has already been jailbroken.

Credit go to the people behind AppSnap, the same utility used to jailbreak 1.1.1 devices. According to TUAW, testing of the new jailbreak began several nights ago, when the new 1.1.2 firmware was made available for download not through iTunes, but through Apple's website.

In its current stage, the new jailbreak requires several steps in order to complete, and is by no means release ready and user friendly. AppSnap and jailbreakme.com still remains open for 1.1.1 only, but the new jailbreak is being prepared for the same single tap installation.

According to TUAW's report, firmware 1.1.1 is required in order for the jailbreak to work with 1.1.2, although it is unclear at this point whether or not this will still be a requirement once AppSnap is officially updated.

Those with hacked 1.1.1 devices may wish to hold off from upgrading to 1.1.2 since it does not appear to provide any significant upgrade. The only noticeable change is the inclusion of several international language packs.

Jailbreaking may become a thing of the past if Apple keeps its promise. Apple announced in early October that come February 2008, developers will have an official iPhone SDK. The announcement was well received by the developer community. Currently, third-party applications for the iPhone are done via web applications and are mostly cumbersome to use and slow in nature.


Comments     Threshold


This article is over a month old, voting and posting comments is disabled

RE: Didn't some...
By cheetah2k on 11/12/2007 3:10:26 AM , Rating: 2
Jailbroken yes, but they have not released a "dummies installer package" to jailbreaking 1.1.2 yet. It's still not crystal clear how to get those phones coming back from 1.1.2 to 1.1.1, out of DFU mode after error code 1015 on a Windows PC.

Anyways, after I bought a 1.1.2 phone yesterday, I simply restored it to 1.0.2, jailbreak'd it, and unlocked using anySIM 1.2. Easy as pie, and no need to even look at 1.1.2 just yet - so easy i'm laughing!

I'll wait until its as easy as jailbreakme.com before attempting 1.1.2 again.

My 2 cents


"This is about the Internet.  Everything on the Internet is encrypted. This is not a BlackBerry-only issue. If they can't deal with the Internet, they should shut it off." -- RIM co-CEO Michael Lazaridis

Related Articles













botimage
Copyright 2014 DailyTech LLC. - RSS Feed | Advertise | About Us | Ethics | FAQ | Terms, Conditions & Privacy Information | Kristopher Kubicki