backtop


Print 70 comment(s) - last by .. on Aug 22 at 12:23 PM

Intel reacts quickly to minimize fallout

A lot of excitement and demand has been built up for Intel's second generation SSDs which use 34nm NAND flash chips produced through a joint venture with Micron. There is a slight reduction in latency, but the big news at launch was the massive price cuts that Intel was introducing.

However, Intel has confirmed that it is delaying shipments of its new SSDs due to a data corruption issue affecting all of the new drives.

The problem occurs when a user sets a BIOS drive password on the new SSDs and then disables or changes the password. If the user powers off the computer, the drive will become inoperable and the data stored on it will remain inaccessible.

However, the problem will not occur if the user has not set a BIOS drive password. This erratum does not apply to computer, network or operating system passwords. Intel claims that the root cause has been identified and a new fix is currently under validation. The company expects to post an end user firmware update to fix this erratum in the next two weeks. It is not yet clear whether the new fix will be able to restore access to data on those drives, or if the firmware update would overwrite that data.
 
Intel is advising their SSD customers to not disable or change their BIOS drive password if they have already created a BIOS drive password.

The issue is reminiscent of Seagate's firmware problems, although on a much smaller scale.
 
Meanwhile, Intel has suspended all shipments of the new SSDs until the firmware fix is validated and installed on the drives. Online retailers like Newegg and ZipZoomFly have also pulled the new drives from their ordering systems.

Update: Data that has been locked out will not be recoverable, according to a email from a representative of Intel.

"The data on a user's drive is only at risk if they have enabled the BIOS
password, then disabled or changed it, rendering the SSD inoperable. The
data on those drives data is not recoverable. The firmware fix will prevent
the drive from becoming inoperable when using and modifying the BIOS
password."



Comments     Threshold


This article is over a month old, voting and posting comments is disabled

RE: Problem? serious one?
By PhoenixKnight on 7/30/2009 10:35:10 AM , Rating: 2
I have an Audigy 2 ZS, and I can't get it working under Windows 7 at all. The driver setup from Creative keeps telling me that it doesn't find any suitable hardware.


RE: Problem? serious one?
By Souka on 7/30/2009 11:29:37 AM , Rating: 2
My old PCI (not PCIe) SB X-FI Fata1ity-pro card runs great under Windows 7 64-bit. Increased my framerate in Crysis about 2FPS and sounds are absolutely richer and deep.

Originally used the Windows drivers (can't remember if they were built in or downloaded via Windows Updadte) but didn't see any FPS difference in Crysis and it had only basic controls. After downloading Creative's drivers it worked as it should. :)

I also didn't have problems with this card using Vista 32bit, XP 32bit, and Ubuntu...


RE: Problem? serious one?
By steven975 on 7/30/2009 5:19:21 PM , Rating: 2
Yea, me too. I've had no problem with my PCI Xfi either...at all.

the DVD Audio isn't supported in x64...but it might work...never tried. Note that DVD Audio and DVD movie audio are not the same thing. DVD Audio is MLP compressed...much like Dolby TrueHD.


RE: Problem? serious one?
By MrPoletski on 8/5/2009 6:08:31 AM , Rating: 2
Have you tried enabling any other sound card with your x-fi (I have the elite pro)?

I wouldn't...

what about performing a live mobo bios update with your x-fi drivers loaded (I am NEVER doing that again)?


RE: Problem? serious one?
By MatthiasF on 7/30/2009 11:36:23 AM , Rating: 2
Might be an issue with your motherboard chipset drivers. I had issues with my video card on both version of Windows 7 I used, later discovering the Microsoft drivers for the Intel chipset were at fault.

If you have an Intel-based northbridge, try downloading the driver setup from Intel's website, extract it using 7Zip and then force driver updates on the Intel items in Device Manager to that folder. Intel's drivers should take and it'll correct a lot of PCI and PCI-E issues.


RE: Problem? serious one?
By Ryanman on 7/30/2009 1:54:04 PM , Rating: 4
Nope. I have a 2ZS and it takes a couple hours to get correctly working... in XP.
The programs it comes bundled with are also buggy.

Seriously, if creative could hire a couple decent software engineers the world would be a better place. As it stands they're getting hammered and they totally deserve it.


RE: Problem? serious one?
By theslug on 7/30/2009 4:00:32 PM , Rating: 2
I can't speak for their current sound cards, but they have made some of the best portable media players, like the creative zen.


RE: Problem? serious one?
By Thrawn on 7/30/2009 10:25:38 PM , Rating: 2
I have to completely agree. In the past I had a Creative Nomad Jukebox 2 and it just wouldn't die. When the Battery did eventually die it cost about 5$ for a cell that was slightly smaller dimensions but lasted longer then the old one (so some crazy time like 26 hours at a fairly high volume) and the hard drive was the same except I got a old one from a laptop that was going to be thrown away and used that. So about 175$ for nearly 7 years of life out of a device. (Gave it to my girlfriend and it is still ticking)


RE: Problem? serious one?
By Ryanman on 7/31/2009 7:57:36 PM , Rating: 2
I have a vision M. It's been slammed onto concrete, thrown around, stored in my car at 120+ degrees, and still has had only one hard reset.
Meanwhile creative's software wouldn't ever sync it properly, or convert video to work on it, or work with their other software. Thank god it at least works with WMP.


RE: Problem? serious one?
By PrinceGaz on 7/30/2009 4:40:22 PM , Rating: 3
quote:
The programs it (Audigy 2ZS) comes bundled with are also buggy.


...and bloated, which is why I never bother installing any of them and just use the latest driver for it on the Creative website. The less Creative software on my machine the better, as far as I'm concerned, but as my onboard sound is the cr@ppy ALC850 and the only alternative I had to hand was a 2ZS, well I guess it does need the drivers.


RE: Problem? serious one?
By Jedi2155 on 7/30/2009 10:25:06 PM , Rating: 2
I have had a number of Creative cards, and had issues with all of them. Mainly driver related, but I do enjoy the higher end sound quality that I get out of them. Actually one of my most enjoyable upgrades from my last big system upgrade was coming from a Audigy 2 to a X-Fi Fatal1ty. The x-fi sound really felt much sharper/cripser natural on my Sony MDR-V6 headphones. However I got the same issues of driver installation as many others and was really annoyed with what Creative did with the Daniel_K situation but I am currently using his drivers on Windows 7 and they work great!


"People Don't Respect Confidentiality in This Industry" -- Sony Computer Entertainment of America President and CEO Jack Tretton














botimage
Copyright 2014 DailyTech LLC. - RSS Feed | Advertise | About Us | Ethics | FAQ | Terms, Conditions & Privacy Information | Kristopher Kubicki